31 Woodbridge Business Park · 452 Koeberg Road · Milnerton

WordPress 3.5.1 Visual Editor Bug & (Hot/Temporary) Fix

After working on ThatLittleShop.co.za (coming soon!) for Mika, I updated WordPress to it’s latest version and then discovered that something had broken… a quick Google for “visual editor in wordpress 3.5.1” lead me to a post that addressed the issue (I assume this will be fixed in later releases).

Excerpt of the post I found :

My visual editor button is visible, but does nothing when I click it. I have deactivated all plugins and I am not running Jetpack. I’ve tried switching themes and problem persists.

Update :

Problem solved by using the following – to fix WordPress visual editor not showing, follow the steps below:

  1. FTP to your web server
  2. Download your wp-config.php and add this line of code at the bottom of the file before the “require_once” line.
define('CONCATENATE_SCRIPTS', false );

(*remember to backup the original wp-config.php)

Should look like that:

/** Sets up WordPress vars and included files. */
 define('CONCATENATE_SCRIPTS', false );
 require_once(ABSPATH . 'wp-settings.php');

» Once done, upload the wp-config.php to your web server again. Now refresh your WordPress page and you should see the Visual Editor now.

With kind thanks to : Fernando via WordPress Support post here.

6 Comments
  • Jeff
    February 23, 2013

    I wish this had worked for me..but it hasn’t. I am desperate for solutions here…I have reinstalled WordPress, changed the config file, deactivated plugins, etc…nothing has worked

    • Lee Stuttaford
      February 24, 2013

      Hi Jeff,
      The bug I reported on I think has subsequently been corrected by WordPress and the hot fix I found and tested was only to have the editor display properly.

      I’ve since installed additional instances of WordPress for other projects with no further issue – so I’m not sure your particular bug is related to the editor?

      Perhaps try to install a pre- 3.5.1 version of WordPress and see if your specific issue continues? That would point to something more WP core / ISP related as the cause, IMHO.

      Best of luck!

  • igorska
    May 22, 2013

    This fix not work for me :( I now try first to downgrade to 3.4.2 , but no luck. Now I will try to downgrade to older version. My original verdsion was 3.1.1 and then everything worked fine.

    • Lee Stuttaford
      May 22, 2013

      Best would be to upgrade to latest version of WordPress, as they fixed the issue in a 3.5.2 minor release.

  • John Bernardo
    July 23, 2013

    This solution not work for me !
    I have WordPress 3.5.2 And i can see Visual tab, and also i have no plugins actived !
    so have you a solutions for that and thanks

    • Lee Stuttaford
      July 24, 2013

      Sorry, John, we’re not seeing that problem occurring on any of our sites – wish I could help!

Leave a Reply

%d bloggers like this: